
 
 

Heartland Positive Pay 
QuickBooks Issue File Export 

 
 

 
This guide is meant to aid users in exporting check file data from QuickBooks. There are two methods of 
exporting the check file data from QuickBooks. Both options are outlined below. These examples are from the 
QuickBooks desktop version. The first option is using a Quick Report from the checking account. The second 
method is using the Check Detail Report, which requires more actions for the user to take. 
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Exporting from QuickBooks Account Register 

1. From QuickBooks, use Ctrl+A to open the account listing from any screen. 
2. Click once to select the appropriate account to pull the Check File. 

 

 
3. Once the Check Report has been populated, use Ctrl+Q to create a Quick Report from the selected 

account. 
 



  

a. Select the Date drop-down menu to choose a specific date or date range for the transactions to 
display in the report. Based on the range that is selected, check items that can be displayed can be 
for a specific date, a specific quarter, month or even a date range that the user selects. 

 

 
b. Click Customize Report button. The Modify Report screen displays. By using the Customize Report 

feature, the user will be able to manage the amount of information contained in the report prior to 
exporting the report to Excel. The user can select and/or remove items that are not needed in the 
report. 

 



  

c. Click the Filters tab. In the listing of Filters, select Transaction Type. This will allow the user to remove 
the transaction types that are needed for the check file. 

 

 
 
 
 

d. From the Transaction Type drop-down menu, select Multiple Transaction Types. This will allow the 
user to select multiple check types within QuickBooks. For this example, we have used Check and 
Bill Payment. Click OK to confirm the transaction types. 
 



  

e. From the Modify Report screen, select OK to proceed. The requested changes to the report will 
display. 

 
 

f. From the QuickBooks toolbar, click the Excel drop-down menu and select Create New Worksheet. 
 

 
g. The Send Report to Excel pop-up window appears. Select Create New Worksheet > In New 

Worksheet and click the Export button to continue. 
 

 
 
 



  

h. Excel will open and the Excel file will populate. Within the Excel file, remove all rows that are blank 
under the column header “Num”. By removing these items from the check file, items that do not have a 
serial number assigned to them will not be uploaded into the Positive Pay System. 

 

 
 

 

 
 
 
 
 
 
 

i. Remove the “Balance” column. This information is not needed for the Check File upload to PRO- 
CHEX. 



  

j. Select File > Save As and save the workbook. 
i. Choose the File Name. 
ii. Choose the Format. The file format for this file must be Comma Separated, Excel 97-2003 

Workbook or Excel Workbook. 

 
 

k. Click Save and close the workbook. 
 
 

4. Login to Business Connect, select the Commercial tab and then the Fraud Protection and EDI Services 
option. 

 

 
 
 
 
 



  

 
a. Select the green Submit button to enter Positive Pay services. 

 

 
 
 
 

 
 
 

5. Select the Heartland Bank Positive Pay Service Module. 
 

 
 
 

6. From the Heartland Positive Pay module, select Manage > Issue Templates to create an issue template. 
This will allow the user to map the exported information from QuickBooks so the file is read correctly 
when uploaded to Positive Pay. The user will also be able to save this template for use in future issuance 
file uploads. 

 
 

 
 
 

 



  

7. The Issuance File Templates page displays. This page lists the saved Issue File Templates available for 
the Client to use and allows the user to create a new template for use. Select Create New Template. 

 

 
 

8. The Create New Template screen appears. 
 
 



  

9. Creating the Issuance Template to the Exported Information from QuickBooks: 
 

a. Template Name 
 

Create a name for the template using information that will allow the user to easily identify this 
template in the future. For this example, the template name is QuickBooks Export Type 1. 

 

 
 
 

b. File Type 
 

Select the appropriate file type based on the file type used to save the Excel document. For this 
example, the file type will be Excel Workbook. 

 

 

c. Template Status 
 

The Template Status drop-down menu defaults to Active status. Leave the status as Active. 
 



  

d. Number of Header Rows 
 

Refer to the Excel file that was created. A Header Row will be any row above the check information 
that does not contain actual check information for presentment in the Positive Pay Module. For this 
example, the header rows have been highlighted yellow. The number of header rows should be 2 in 
the template. 

 

 
 

e. Number of Footer Rows 
 

Refer to the Excel file that was created. A Footer Row will be any row below the check information 
that does not contain actual check information for presentment in the Positive Pay Module. For this 
example, the footer rows have been highlighted yellow. The number of footer rows should be 2 in the 
template. 

 

 
f. Template Level 

 
The default value of Client will be presented and will not allow a different selection to be made. 

 

g. Multi-Line Payee Name Separator. 
 

This feature is not currently available for items exported out of QuickBooks. 
 



  

 

 
 

h. File Mapping 
 

i. Serial Number 
 

1. Enter the column number that the check number/serial number is presented in the Excel 
document. For this example, the Num column is highlighted yellow. The column number for 
Num should be 9 in the template. 

 

 
i. Amount 

 
1. Enter the column number that the amount is presented in the Excel document. Select 

fractional dollars if the dollars and cents are separated by a decimal. If the dollars and cents 
are not separated by a decimal, select whole numbers of cents. For this example, the Amount 
column is highlighted yellow. The column number for Amount should be 17 in the template. 

 
 
 



  

 
ii. Status 

 
1. Remove the checkmark from this box. The export from QuickBooks does not contain this 

information. The user can add this information manually if they choose to. If the column is 
added, the box will need to remain checked and the column number will need to be entered 
for the Positive Pay system to accurately read it. For this example, the Status field is not being 
used. 

 

 
If the Status box is unchecked, the user should be aware that any issuance loaded with 
negative amounts or a $0 amount will be treated as Void. 

 

iii. Account Number 
 

1. The exported information from QuickBooks does not include an account number. Leave the 
box unchecked and the File Column field blank. For this example, the Account Number field is 
left blank. 

 

 
 

iv. Issuance Date 
 

1. The Issuance Date is located in the “Date” column in the Excel document. The user must 
check the box and enter the column number for the system to read the issuance date 
correctly. For this example, the Date column is highlighted yellow. The column number for 
Issuance Date should be 7 in the template. 



  

 

 
v. Payee Name 

 
1. If the Client is set up to use Payee Positive Pay, the user will need to select the box and enter 

the column number for the column labeled “Name” in the Excel report. For this example, the 
Name column is highlighted yellow. The column number for Payee Name should be 11 in the 
template. 

 

 
 

vi. Additional Issue Fields 
 

1. Additional issue fields are available for client use to allow clients to record any additional 
information into an issuance file to be used for historical or reconciliation purposes. In the 
example below, the client has additional issue fields configured: Company Name, Invoice, 
and Address. For the purposes of Export from QuickBooks, the user should disregard these 
fields as they do not apply to the export process. 



  

 

 

vii. Click the Save button. A success message appears, and the user will be returned to the 
Issuance Templates page. The new issue template will display in the list of templates. 

 

 
 

 
 

  



  

Exporting from QuickBooks Reports 
10. From QuickBooks, select Reports on the Tool Bar. 

 
 

 

11. Select Banking from the drop-down menu and click Check Detail from the Banking sub-menu. 
 
 

 
 
 
 
 
 
 
 
 



  

12. The Check Detail Report will display. 
 
 

 
 

a. Select the Date drop-down menu to choose a specific date or date range for the check items to 
display in the report. Based on the range that is selected, check items that can be displayed can be 
for a specific date, a specific quarter, month or even a date range that the user selects. 

 

 
 
 
 
 
 
 
 
 
 



  

b. Click Customize Report button. The Modify Report screen displays. 
 

 
c. Select the Filters tab. 

 
 

 
  



  

 
d. In the listing of Filters, select Account from the drop-down menu. 

 
i. Select All Bank Accounts to pull all checks issued from all bank accounts for which the user has 

QuickBooks access. 
 

 

ii. Select a single Bank Account to pull checks issued from a single bank account. 
 
 

 
 
  



  

iii. Under Include Split Detail?, click the button next to “No”. 
 
 

 

iv. Under Current Filter Choices, select Detail Level, and then click the Remove Selected Filter 
button. 

 

 



  

v. Select Transaction Type from the Filter menu. Select Multiple Transaction Types from the 
Transaction Types submenu. 

 

 
vi. From the Select Transaction Type drop-down menu, select the check transactions to appear in 

the Check File. For this example, Check and Bill Payment options were selected. Click OK to 
confirm the transaction types. 



  

 
e. From the Modify Report screen, select OK to proceed. The requested changes to the report will 

display. From the QuickBooks toolbar, click the Excel drop-down menu and select Create New 
Worksheet. 

 

 
f. The Send Report to Excel pop-up window appears. Select Create New Worksheet > In New 

Worksheet and click the Export button to continue. 
 

 
  



  

g. Excel will open and the Excel file will populate. Within the Excel file, remove all rows that are blank 
under the column headers “Type” and/or “Num”. 

 

 
 
 

h. Remove all blank columns. 
 

 



  

i. Select File > Save As and save the workbook. 
 

i. Choose the File Name. 
 

ii. Choose the Format. The file format for this file must be Comma Separated, Excel 97-2003 
Workbook or Excel Workbook. 

 

 
 

j. After saving, close the Excel workbook. 
 

13. Sign into Positive Pay by accessing the Commercial Tab and selecting the Fraud Protection and EDI 
Services option. 

 

 



  

 
a. Select the green Submit button to enter Positive Pay services. 

 

 
 
 
 

 
14. Select the Heartland Bank Positive Pay Service Module. 

 

 
 

 

15. From the Positive Pay module, select Manage > Issue Templates to create an issue template. This will 
allow the user to map the exported information from QuickBooks so that the file is read correctly when 
uploaded to Positive Pay. The user will also be able to save this template for use in future issuance file 
uploads. 

 
 



  

16. The Issuance File Templates page displays. This page lists the saved Issue File Templates available for 
the Client to use and allows the user to create a new template for use. Select Create New Template. 

 

 
 

17. The Create New Template screen appears. 
 
 



  

18. Creating the Issuance Template to the Exported Information from QuickBooks: 
 
 

a. Template Name 
 

Create a name for the template using information that will allow the user to easily identify this 
template in the future. For this example, the template name is QuickBooks Export Type 2. 

 

 
 
 

b. File Type 
 

Select the appropriate file type based on the file type used to save the Excel document. For this 
example, the file type will be Excel Workbook. 

 

 
 

c. Template Status 
 

The Template Status drop-down menu defaults to Active status. Leave the status as Active. 
 



  

d. Number of Header Rows 
 

Refer to the Excel file that was created. A Header Row will be any row above the check information 
that does not contain actual check information for presentment in the Positive Pay Module. For this 
example, the header rows have been highlighted yellow. The number of header rows should be 2 in 
the template. 

 

 
 

e. Number of Footer Rows 
 

Refer to the Excel file that was created. A Footer Row will be any row below the check information 
that does not contain actual check information for presentment in the Positive Pay Module. For this 
example, the footer rows have been highlighted yellow. The number of footer rows should be 2 in the 
template. 

 



  

f. Template Level 
The default value of Client will be presented and will not allow a different selection to be made. 

g. Multi-Line Payee Name Separator. 
This feature is not currently available for items exported out of QuickBooks. 

 

 

h. File Mapping 
 

i. Serial Number 
 

1. Enter the column number that the check number/serial number is presented in the Excel 
document. For this example, the Num column is highlighted yellow. The column number for 
Amount should be 2 in the template. 

 



  

ii. Amount 
 

1. Enter the column number that the amount is presented in the Excel document. Select 
fractional dollars if the dollars and cents are separated by a decimal. If the dollars and cents 
are not separated by a decimal, select whole numbers of cents. For this example, the Amount 
column is highlighted yellow. The column number for Amount should be 6 in the template. 

 

 

iii. Status 
 

1. Remove the checkmark from this box. The export from QuickBooks does not contain this 
information. The user can add this information manually if they choose to. If the column is 
added, the box will need to remain checked and the column number will need to be entered 
for the Positive Pay system to accurately read it. For this example, the Status field is not being 
used. 

 

If the Status box is unchecked, the user should be aware that any issuance loaded with 
negative amounts or a $0 amount will be treated as Void. 



  

iv. Account Number 
 

1. The exported information from QuickBooks does not include an account number. Leave the 
box unchecked and the File Column field blank. For this example, the Account Number field is 
left blank. 

 

 
 
 
 

v. Issuance Date 
 

1. The Issuance Date is located in the “Date” column in the Excel document. The user must 
check the box and enter the column number for the system to read the issuance date 
correctly. For this example, the Date column is highlighted yellow. The column number for 
Issuance Date should be 3 in the template. 

 
vi. Payee Name 

 
1. If the Client is set up to use Payee Positive Pay, the user will need to select the box and enter 

the column number for the column labeled “Name” in the Excel report. For this example, the 
Name column is highlighted yellow. The column number for Payee Name should be 4 in the 
template. 



  

 

 
vii. Additional Issue Fields 

 
1. Additional issue fields are available for client use to allow clients to record any additional 

information into an issuance file to be used for historical or reconciliation purposes. In the 
example below, the client has additional issue fields configured: Company Name, Invoice, 
and Address. For the purposes of Export from QuickBooks, the user should disregard these 
fields as they do not apply to the export process. 

 
 



  

i. Click the Save button. A success message appears, and the user will be returned to the Issuance 
Templates page. The new issue template will display in the list of templates. 

 
 

 

Loading the QuickBooks Issue File 
 

19. From the Heartland Positive Pay Module, select Perform > Issue File Load. 
 

 
 
 

20. The Load Check Issuance File page appears. 
 
 

 
 

21. Select the Template drop-down box to select from a list of existing templates. Select the appropriate 
template. For this example, QuickBooks Export Type 2 will be used. 



  

 

 
22. The template selected was created without the Account field enabled. A drop-down box will display so 

that the appropriate account can be selected. Select from the list of accounts. For this example, ABC 
Heating – xxxx1555 will be used. 

 

 
 

23. The file upload interface will appear. Click the Browse button to select the appropriate file or drag and 
drop the file into the box indicated on the interface screen. 

 



  

24. Once the file is selected, it will be displayed in the upload interface. 
 
 

 

25. Click the Upload button to proceed. Once the file has loaded successfully, the 
Issuance File Status page will display and will be eligible for editing in the Issue 
Warehouse. 
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